Can't Checkout JPatch - missing image icons

Anything related to a beta release of JPatch: Bugs, enhancements, general discussion...

Can't Checkout JPatch - missing image icons

Postby pndragon » Sun Aug 20, 2006 2:29 am

Trying to checkout the latest from svn I keep getting this message:

Cannot Checkout Project

From the console (after many lines without problems)...
Code: Select all
   Problem running log
svn: In directory 'C:\eclipse\jpatch\JPatch\src\jpatch\images\icons_16x16'
The system cannot find the file specified. 
svn: Can't copy 'C:\eclipse\jpatch-SVN\JPatch\src\jpatch\images\icons_16x16\.svn\tmp\text-base\spotlight.png.svn-base' to 'C:\eclipse\jpatch-SVN\JPatch\src\jpatch\images\icons_16x16\spotlight.png.tmp': The system cannot find the file specified.


--- Jim
"We're so sorry, Uncle Albert,
But we haven't done a bloody thing all day."
--- Paul McCartney
pndragon
 
Posts: 591
Joined: Sun Dec 05, 2004 1:27 am
Location: North Carolina

Postby sascha » Sun Aug 20, 2006 9:38 am

I've had some problems committing the latest version too - I'll have to check.
At the moment the development version is not functional, so you won't be able to do much with it. The latest "working" version was the one I've uploaded as jar file.
I'm currently working on the modeler, integrating Torf's changes and refactoring some very old classes. It will take some more time, I'll let you know as soon as there is something to show.

When it's done there should be several improvements:
* Multiple open files, seperate undo-managers for each.
* Improved tools (move, scale, rotate)
* Smart "append" - when appening two curves, JPatch will choose the best one, depending on the direction of the curve segments. Currently it welds to the first curve it can find (if there are multiple possibilities).
* Smart "lasso select" - it will decide wheter to select all points in the rectangle or just visible (i.e. not obscured by patches in front of them) points.
* Toggling between hook and non-hook
* Bugfixes and faster operations (currently some operations are incredibly slow - e.g. deleting large selections).
sascha
Site Admin
 
Posts: 2792
Joined: Thu May 20, 2004 9:16 am
Location: Austria

Postby pndragon » Wed Oct 04, 2006 7:37 pm

I'm still having this problem...

Is it just me?

I've tried deleting the repositories. I've tried deleting the projects and starting from scratch. I've tried opening new workspaces and starting from scratch.

--- Jim
"We're so sorry, Uncle Albert,
But we haven't done a bloody thing all day."
--- Paul McCartney
pndragon
 
Posts: 591
Joined: Sun Dec 05, 2004 1:27 am
Location: North Carolina

Postby sascha » Wed Oct 04, 2006 8:22 pm

Hi Pndragon,

I'm not sure what's causing the problems, but it doesn't matter 8)

Seriously, JPatch is at the moment in a completely unusable state. I'll put something online as soon as I've got something to show, and I'll fix the SVN issues by then.

For the time being, please use either JPatch0.4 (with a reasonalbly stable modeler) or the latest version from here http://www.jpatch.com/temp/jpatch_20060527.jar
(with some nice animation features, but some bugs as well).

Squirrelhavoc reported a problem when rendering an animation on windows - I'll try to find and fix it and maybe put the code fom 05/2006 "officially" online as JPatch0.5.3.

What I'm currently working on is a rewrite of some core components - of course I use a lot of the JPatch 0.5.2 code, but when it's done I think that the new code won't share a single line with JPatch 0.4 (I'm not sure if this is a good or a bad sign ;-) ), so I think it will justify a version jump to 0.7...
sascha
Site Admin
 
Posts: 2792
Joined: Thu May 20, 2004 9:16 am
Location: Austria

Postby pndragon » Thu Oct 05, 2006 4:26 pm

Sorry Sascha. :oops:

I've been spoiled by being able to play with the nightly builds... I'm starting to seriously miss my fix...

--- Jim
pndragon
 
Posts: 591
Joined: Sun Dec 05, 2004 1:27 am
Location: North Carolina

Postby sascha » Thu Oct 05, 2006 7:39 pm

No reason to be sorry :)
I'm starting to seriously miss my fix

:oops: I'm afraid I can't remember (you know, we've got our second baby and besides that there's a lot of other work to do) - did I promise anything?
I actually discontinued the 0.5.2 code, but if there's something I can fix quickly and you're waiting for I'll do it (and put a 0.5.3 online).
sascha
Site Admin
 
Posts: 2792
Joined: Thu May 20, 2004 9:16 am
Location: Austria

Postby pndragon » Thu Oct 05, 2006 8:00 pm

No, you didn't promise anything. I just like to play with everything before anyone else. It's a bad habit. My kids never get anything that hasn't been pre-played with either.

I also understand completely the lack of time. My little girl is just now starting to take those first steps. Baby fingers are into everything. She has developed a fascination with my computer... Also our home network crashed and burned last week... Busy, busy, busy.

--- Jim
"We're so sorry, Uncle Albert,
But we haven't done a bloody thing all day."
--- Paul McCartney
pndragon
 
Posts: 591
Joined: Sun Dec 05, 2004 1:27 am
Location: North Carolina

Postby sascha » Thu Oct 05, 2006 8:03 pm

Well, as I said earlier - I'll try to figure out what's causing the problems Squirrelhavoc reported with rendering on Windows (the latest JPatch 0.5.2.cvs) - if I can fix it I'll put a fixed version online - so if there's something else I can quickly fix in the old 0.5.2 code please let me know.
sascha
Site Admin
 
Posts: 2792
Joined: Thu May 20, 2004 9:16 am
Location: Austria


Return to Beta

Who is online

Users browsing this forum: No registered users and 1 guest

cron